SSL Problems (Can't find server.*.pem)

If you're having any problems with UnrealIRCd 3.2.x, post them here, and someone in the community will help you out.

Moderator: Supporters

SSL Problems (Can't find server.*.pem)

Postby AzzKikr » Wed Aug 18, 2004 9:04 am

Howdy.

Just compiled Unreal 3.2.1, config it for SSL and such. But getting these weird errors when I go to run it:

[Wed Aug 18 08:29:32 2004] - Failed to load SSL private key server.key.pem
[Wed Aug 18 08:35:22 2004] - Failed to load SSL certificate server.cert.pem
[Wed Aug 18 08:37:22 2004] - Failed to load SSL certificate server.cert.pem
[Wed Aug 18 08:37:29 2004] - Failed to load SSL certificate server.cert.pem
[Wed Aug 18 08:42:14 2004] - Failed to load SSL certificate server.cert.pem


Any ideas what I'm doing wrong? The server is running the latest build of Gentoo.

Cheers!
AzzKikr
 
Posts: 5
Joined: Wed Aug 18, 2004 9:00 am

Postby AngryWolf » Wed Aug 18, 2004 9:28 am

If these errors are weird to you, I strongly recommend you to learn about SSL first.

To create those .pem files (actually self-signed certificates), type make pem in the Unreal3.2 source directory. If you'd like to encrypt your server key, type make encpem.

Normally these files are created right after ./Config finishes. Probably the certificates are missing because you have run "make install" after the compilation had been done. You should know that .pem files don't get installed with that command, you must install them manually in that case. Or if you haven't run "make install", just forget what I said about it.
AngryWolf
 
Posts: 554
Joined: Sat Mar 06, 2004 10:53 am
Location: Hungary

Postby AzzKikr » Wed Aug 18, 2004 9:50 am

AngryWolf wrote:If these errors are weird to you, I strongly recommend you to learn about SSL first.

To create those .pem files (actually self-signed certificates), type make pem in the Unreal3.2 source directory. If you'd like to encrypt your server key, type make encpem.

Normally these files are created right after ./Config finishes. Probably the certificates are missing because you have run "make install" after the compilation had been done. You should know that .pem files don't get installed with that command, you must install them manually in that case. Or if you haven't run "make install", just forget what I said about it.


Sorry... I know what the pem files are, it's just that I've never set up the server on Linux before.
I've created a new .pem file, and every time I go to run Unreal again, the errors continually appear. Do I need to copy the .pem files anywhere, or are they copied when I make pem?

Cheers!

EDIT: Copied files across to /ircd directory, and all good. Thanks for the help!
AzzKikr
 
Posts: 5
Joined: Wed Aug 18, 2004 9:00 am

Postby AngryWolf » Wed Aug 18, 2004 10:12 am

Ok, but why to quote my entire previous post? Do you like reading duplicated texts? If I send 10 pages of text, would you quote it in your next answer?

AzzKikr wrote:Do I need to copy the .pem files anywhere, or are they copied when I make pem?

The "make pem" command creates the files in the Unreal3.2 source directory. If you used non-default paths in ./Config (2nd and 3rd questions), then yes, you need to copy them to that directory where your server configuration files are in.

I know the problem has been solved, these clarifications are only for the archive. :)
AngryWolf
 
Posts: 554
Joined: Sat Mar 06, 2004 10:53 am
Location: Hungary


Return to Unreal 3.2 Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest